You must be logged in to reply.

Page 3 of 3 out of 30 messages.

Scary G120 (Cobra II eco) NetMF, System.Text.UTF8Encoding, System Exception

Reply #20 — Posted 4yr ago
by Reinhard Ostermeier | King | 37,718 exp
Reply #20 — Posted 4yr ago
by Reinhard Ostermeier | King | 37,718 exp
Architect says:
@John - FYI, I had to go with TeraTerm last week. Couldn't update my Cobra II using FEZ Config. COM Port was visible in Device Manager, but FEZ Config acted like it was not.

I had this once with my Cobra or Raptor, can not remember exactly. The root cause was, that I also had an USB Serial module connected to my PC (this one https://www.ghielectronics.com/catalog/product/287 ). Once I disconnected the USB Serial, everything went like normal.
I guess FEZConfig looks for some specific USB Serial chip, and tries to use the 1st it can find.
Reply #21 — Posted 4yr ago
by John_ghielectroncs | Employee
Reply #21 — Posted 4yr ago
by John_ghielectroncs | Employee
@mhardy - FEZ Config is your best bet to update TinyBooter. You can contact us for an RMA and if we find the board is defective we can issue a refund or replacement. If you want to be sure, you can test on a second Cobra II before sending yours to us.
Reply #22 — Posted 4yr ago
by Architect | Immortal | 176,996 exp
Reply #22 — Posted 4yr ago
by Architect | Immortal | 176,996 exp
@Reinhard Ostermeier - In my case there were nothing else connected.
Reply #23 — Posted 4yr ago
by Reinhard Ostermeier | King | 37,718 exp
Reply #23 — Posted 4yr ago
by Reinhard Ostermeier | King | 37,718 exp
@mhardy - When there is a bootloader and a valid firmware on the board, you will se some "GHI..." device in the device manager, no COM port.
If you start the board in loader mode (push the buttons for about 2 sec. during power up) it will show up as COM-Port again.
Reply #24 — Posted 4yr ago
by Reinhard Ostermeier | King | 37,718 exp
Reply #24 — Posted 4yr ago
by Reinhard Ostermeier | King | 37,718 exp
@Architect - Was a wild guess. But @John: how does FEZConfig select the right COM-Port, if there are more than one?
Reply #25 — Posted 4yr ago
by mhardy | Junior | 590 exp
Reply #25 — Posted 4yr ago
by mhardy | Junior | 590 exp
OK, I will place an order.

The RMA is not that important to me. Finding the root cause is.
When you get an RMA, can it be marked for failure analysis?
Reply #26 — Posted 4yr ago
by mhardy | Junior | 590 exp
Reply #26 — Posted 4yr ago
by mhardy | Junior | 590 exp
Reinhard,

Just tried what you said....Worked just as you said....thanks
Reply #27 — Posted 4yr ago
by John_ghielectroncs | Employee
Reply #27 — Posted 4yr ago
by John_ghielectroncs | Employee
@mhardy - We look at all products we receive through RMA to try and determine the problem.
1 like
Reply #28 — Posted 4yr ago
by mhardy | Junior | 590 exp
Reply #28 — Posted 4yr ago
by mhardy | Junior | 590 exp
John -

Received new Cobra II (eco) this morning and have been running it since.

Works as expected, i.e. no lockup or spewing of crash reports. At a count of ~ 20,000,000 cycles now. On old board I was lucky to get to a count of ~30,000 or so.

Surprising, each loop takes about 1ms to complete.........
Reply #29 — Posted 4yr ago
by Brett | Superhuman | 125,590 exp
Reply #29 — Posted 4yr ago
by Brett | Superhuman | 125,590 exp
that's great follow up, and good to hear you're now progressing !

Page 3 of 3 out of 30 messages.

You must be logged in to reply.